1. 11
  1.  

  2. 2

    Sorry for having the first comment you receive be a (minor) complaint about a platform you likely weren’t targeting. On Firefox on Android, attempting to type ,help makes the help text briefly appear before quickly vanishing. This makes it a tad difficult to understand what this does without resorting to finding it on your GitHub. :P

    (Without having looked into it from a computer, and therefore meaning I don’t know what’s actually happening, my guess would be that this is something to do with changing content when the cursor position changes?)

    1. 4

      Hi @zgrep, Thank you for reporting this issue with detailed information. It helped me to reproduce the issue with Firefox on Android. The issue was caused by a second input event being fired when the text input field was being changed by the tool itself. Apparently, this behaviour seems to occur only with Firefox on Android. This behaviour does not seem to occur with the other browsers I had earlier tested with like Firefox on macOS, Chrome on macOS, iOS, and Android.

      I have now pushed a fix to resolve this issue. The issue you faced should be resolved now. Thanks, once again, for taking a close look at this tool, reporting this issue, and helping me to improve it!

    2. 2

      This is great!

      Any chance to have the UX of drawing with chalks on the board? Having Free Drawing + Math will be a real scribbling board.

      After that, live joint editing :-).

      1. 1

        Cool! A very minor glitch: in the example document you have a_1 = a_2 = dots = a_k = 1, which renders “dots” literally where you wanted an ellipsis “…”. I’ve long since forgotten all the TeX I knew, but adding a backslash before “dots” fixed it.

        1. 1

          Hi @snej! That was indeed an error. Thanks for reporting it. Fixed it now.