1. 17
  1.  

  2. 2

    Now you can specify the version of Ruby in the Gemfile. That’s big for deployment to Heroku.

    1. 4

      It’s also useful for a fail-fast for people on your team using the wrong version of Ruby, and for rvm, which will use the information in the Gemfile to switch to the right version for you.

      1. 2

        I’ve updated my articles to point out the need to update Bundler:

        @wycats I’m looking forward to Tokaido so I can cut the Installing Rails article down to one paragraph.

      2. 2

        Other comments explain why the Ruby version directive is awesome. Here are some reasons why the other features are:

        Packaging :git and :path Dependencies – Makes it a snap to vendor all your gems for when your target machines have no internet.

        Local git repos – Lets you develop a project and the gems it depends on in parallel without having to change the Gemfile for the project that depends on the gems or push the gems unnecessarily.

        Thanks team bundler!

        1. 1

          Excellant news. Looking forward to seeing the ruby versioning in gemfiles get adopted. This should also simplify testing on different rubies without hacking around with rvm / rbenv files :)