1. 16
  1.  

  2. 2

    What’s the new workflow to use regex, glob, crypto packages? Do these “just work” if installed from source with the Pony package manager?

    1. 2

      Not quite. Not yet anyway.

      If you have the proper library be it openssl or pcre2 installed then bringing in regex, crypto, or net-ssl will work.

      Glob has a transitive dependency on regex do you need to tell the package manager to bring in both.

      Carl Quinn has been working on a new package manager that handles transitive dependencies. With it, the situation is better.

      But neither of the package managers that exist will help with the c library issue .

      Or plan is to deprecate the existing package manager, stable, and replace it with the much more full featured one, corral, that Carl has been working on.

      We are still figuring out the system library issue but hope to address that using corral as well.