1. 13
  1. 3

    U-Boot 2012.07

    That’s a rather ancient U-Boot. In particular, it is vulnerable to some FIT bugs found in the past few years. CVE-2021-27138 and CVE-2021-27097 may result in secure boot for Linux being broken. Of course, they may just sign the entire FIT, neatly working around the problem.

    1. 2

      What a MOTD :) Some engineers had some fun there.

      popular Qualcomm IPQ4018 SoC

      Coincidentally, FreeBSD is starting to run on that one like right now (e.g.)